Start a new topic

wrong time stamp

this camera always show wrong time stamp . i need to be correct time many time in a day. when ever i shut off my car and start again time change. so this is a major problem about this camera. other wise video quality is good.

My settings are: Underlined items are the ones which always resets settings 

Using 32Gb SD card FAT32

Resolution: 1920x1080 30fps

Loop Rec.: 2 min

EV: 0


Time-Lapse: OFF

Motion Dect.: OFF


G-Sensor: Med


Plate Stamp: inserted

Rec. Audio: OFF

Screen Saver: 30s


Date/Time: ON DDMMYY

Time Zone: -3

Lang.: English

Beep: Only Buttons

Freq.: 50Hz

Format: -  (Used once)

Format Warn;: 15days

Default: (used once)

Version: A119_170606_V3.1

When you change each setting, are you pressing the emergency ( ! ) button to confirm the change before returning to the main menu?

1 person likes this

Can someone be so stupid as I am ? No ! I was not pressing the (!) button after selecting config. I was pressing the MENU button, as immediately over this button apears the OK sign... Now I reconfigured my A119 and it holds the settings. Just GPS functions I´ll have to try later in the car.  Thank you (CaptureYourAction), checked you input and was surprised that this is mentioned in the manual. I´m stupid, thanks a lot !!!

Glad it's working for you.


Actually it has a small RTC battery on the board and mine seems to have also packed up. Loses settings everytime I switch off, and because the default setting for GPS is Off, I have to manually set that as well as the timezone every time I start my car. Dashcam is only one year and 6 months old.

The RTC battery only holds the Time and Date.  If your losing other settings, it has nothing to do with the RTC battery.  Make sure your pressing the ! button to confirm each setting change.  If you change a menu setting and don't press the ! button to confirm, your new setting will not hold.  If your still losing all your settings, update the firmware (or reinstall it).  Make sure you manually default the cameras settings in the menu after the update.


Login or Signup to post a comment