Start a new topic

Last file of each drive corrupted

Hello,

I received yesterday my Viofo A119 (my first dashboard camera). I installed it today and tested it. It works, but I have a problem: the last file of each drive is corrupted. On the camera itself, it isn't shown at all; on the PC, I can see the file but every player I have say it's corrupted.

The camera is set to GPS on, 1080P/30, LDWS on, 5 minute loop.

The firmware is 1.1, and the SD card is a genuine Sandisk 32GB class 10.

Is this a known issue? I would expect the last file to be saved, especially since any accident would be at the very end of a drive...


Thank you,

Cristian


I received my replacement A119 dash camera today, removing the old bad one and installing the new one.  I ran a test to be sure the last file was saving okay, and it was.  The problem with the last file not being saved, at least on my old A119 device, is that the capacitor was not working anymore so when the car power was turned off, and with the capacitors were bad, there was no reserve power left to close down the last file write properly.  The capacitors have to be working correctly so there is still power to the dash cam to finish the last file.  You can tell if it is working properly as the REC light needs to be lit up after the power is turned off to the camera.  


My first camera lasted about a week before the capacitors went bad.  I will keep track of how this is doing, and report back here, as well as contact the company I purchased it from to let them know.


BTW, I am not using GPS on my unit.


Overall I am very pleased with the dash camera.  I just need the capacitors to keep working on this new unit.

We have updated the manual, power on the camera from GPS mount or side USB port, the GPS features still works.

Thanks for the helpful advice Dave....

I was having the exact same problem as you (brand new camera).  I just tried plugging power direct into the camera and it does work without corruption but still retains GPS data.  This is contrary to the manual which states power must be connected to the GPS module.  Give it a shot!

Mindaugas, if you are using the GPS mount, try plugging directly in the camera instead.  I would also try powering the camera with a USB charger (phone charger with 1A minimum).  Let the capacitors charge for a couple of minutes, then pull the power.  Wait about 20 seconds for camera to fully power down, then pull the card and check last file.
If none of this works, try reinstalling the firmware.  Some have had luck with it.

 

Will be very interested to see what VIOFO say in reply to this apparent common issue with their camera on what could be the difference between capturing the last seconds of an unfortunate accident or not..

I am still having this issue with my Viofo A119S. This is my second camera as I returned the first one thinking the capacitor is broken however now the replacement one is doing the same. This makes me think that this is a fault with the product it simply is not saving the last file once car is switched off. If you press the record button to stop it recording manually the file will save however this is quite inconvenient. I have the newest firmware so that is not the issue either. Upsetting really because the dash cam itself is very good quality but this one fault is making me want to return the product and buy a different dash cam. I have filed a support ticket however and will wait for response before doing this.

I mean "now" recommend... sorry for the typo

I reinstalled the latest version, 2.02 which came with my camera, and it did not make a difference.


My camera is powered from the inner fuse box, the ACC connection normally.  I have tried every variation on powering the cam, still no to use on the very last video file recorded.  I sent an email to the company I purchased it from to see what they not recommend.  For my case I can only think of returning it and getting a new one now.

Not sure what firmware version people were on before they upgraded, but keep in mind that if your camera had a version earlier than 2.0, you needed to upgrade the loader file as well. As always, don't forget to default your settings after updating.

Initially I completely forgot to notice that I've been using the same power adapter to charge my phone. I'm not yet 100% certain, but it could be due to the fact that the phone might also be draining the power from the capacitor if the electronics don't isolate the circuits completely. 


I did test the theory over a couple of days and it seems to be working better without the phone attached at the time I turn off the ignition effectively cutting the power from the dashcam.


There are still some of the trailing video files broken, but it seems it is better overall. Need to test a bit more though.

Thanks, Cristian. I am wondering if I reinstalled the latest version if that may resolve my issue.  I just came from the car doing a default setting on the camera hoping that would help - no luck.  reformatted the SD card, tried different resolutions.  Most everything on my unit is turned off as 


I am going to try to redo the V2.02 firmware version, the last thing I can think of to try.  I may just have ended up with a bad capacitor, and those things happen.  So far I have been very pleased with the A119 Unit, minus the last file issue.  I would recommend this dash cam to anyone.


I will give an update later on once I finally do a refresh of V2.02.

For what it's worth... I'm the original poster, and after upgrading the firmware to the latest version, I've never had any more corrupt files. The camera just works, consistently, and I also bought a second one for my wife's car. That too is working fine. The camera light does stay on for a few seconds after shutting down the car. I have disabled all the lane change warning and the rear-ending warning, I don't know if that may make a difference.

1 person likes this
When you manually power down, the camera has power the entire time.  When the camera shuts down due to car turning off, it no longer has power.  It's the capacitors job to hold enough power so the camera has enough time to save the last file.  If the capacitor is bad, then the camera won't have enough time, causing the file to become corrupt.

 

Thanks.  I have tried using the USB, trying both the 1A and 2.1A ports leaving it charging/running for about 5 minutes and still encounter the same issue.  I will have to get back to the seller to return the camera unless there is some new software version to try to use. 


Odd thing is when I hit the Power button on the camera to turn it off, then the last recording gets saved; but when the car is turned off the the last recording is not good.  I am not sure what the difference is between hitting the power button on the camera to turn it off and the car being turned off, not sure if the capacitors are to be used in both situations.

Login or Signup to post a comment