Start a new topic

A119S loses all settings when powered off.

I have a new A119S (firmware A119S_170222_V1.2). I enter all of my setting in the menu including things like Frequency, Time Zone, Screen Saver, WDR, Speed Unit…etc. When I turn off my car, power is no longer available to the camera so it shuts off. When I repower the camera, it has lost all setting with the exception of Date/Time. I hope this is not expected behavior as I do not think having to re-enter my desired settings everytime I turm my car on is very convenient.

2 people have this problem

Make sure you are pressing the OK button (! Button) after changing each setting. If you change the setting then press menu, you will loose your setting. Also, did you update to v1.2 or did the A119S come with it already. If you installed it, did you default your settings in the menu after the update? Do so if you did not.

1 person likes this

I have the same issue.  

I have a new A119S, and it seems to be working well enough.  However, when I change any settings, they are not being maintained after I remove the power.  Resolution, G-Sensor sensitivity, beep preferences, etc.  They are all find until I cut the power.  But when I return, they are no longer their.

I have upgraded to the latest firmware.  And I have done a settings reset.  Neither made much of a difference.

My process is to:

  1. Stop Recording
  2. Press Menu to enter the settings
  3. Change the preferred setting
  4. Commit the change by pressing !
  5. When done, press MENU again to go back to recording mode.
At this point, the new setting seems to be working.  But once I cut the power (turn off the vehicle) the settings are lost.

Any thoughts?

For such issue, first please try to reload the firmware, and reset it to default settings.

Second try to power on the camera from side USB port.

If above steps can not solve the issue, please check if the LED will be immediately off after unplug the charger.

view my SETUP video for steps on saving settings correctly

I have a A119s dash cam which seems to work fine. But when I power off, any settings I have put in are not being saved.. I have reinstalled firmware (V2.2) and gone to the default settings and punched in my preferences, but there seems no way of saving those preferences. What is going on? I have done this procedure many times and find it very frustrating!


Have you tried the above suggestions?  This behavior is usually caused by not pressing the ! button to confirm your setting change.  If this does not help, I would reload the firmware (again) and default your settings after the reload.  If that still does not help, I would load V2.1 and see if that makes any difference.


I have tried all of the above suggestions about 10 times, over and over again. The only thing I haven't tried is reformatting using firmware V2.1 in stead of using V2.2. are you able to supply a link to a V2.1 firmware site? I can't find it on the Viofo website at all! Regards.


I wouldn't worry about it mate.  These units are shit.  I would pick up a different one and call it a day.

My first one was horrible.  Support was poor, slow and unclear.  To their credit, they did send me a replacement.  But that unit also failed quickly.  After that second unit, they were completely unresponsive.  No third unit.  No refund.  

I ended up buying a completely different brand.  

Doesn't seem to want to let me post a link here.  Go to CaptureYourAction dot com and you will find the A119S firmware under the Downloads section. 


Thanks. I have downloaded the V2.1 firmware and gone through the process of resetting my preferences etc., but still no joy. When power is on all is OK, but as soon as I turn the power / car off all preferences go to default. So not real happy about having to reset everything every time I want to use it.


Is this a V1 or V2 model? Are you powering through the GPS mount? How are you powering the unit when your adjusting the settings? Try changing the settings without a memory card inserted.
The VIOFO Dashcams will lose time and settings after :
  1. changing Firmware
  2. insufficient 5volt or 1amp power
  3. intermittent connectivity caused by Version1 gold-pin GPS module
  4. intermittent connectivity caused by right-angle mini-USB adapter
  5. drained RTC rechargeable battery
Recommended solutions :
  1. update Firmware using indoor 5volt 1-3amp power adapter (not power bank)
  2. swap out current power source as a test
  3. all Version1 GPS modules are junk, contact seller for replacement or clean contacts
  4. all right-angle mini-USB adapters are junk, throw it away
  5. connect A119S to indoor 5 volt power adapter or power bank and keep on for 5 hours or more
Visit my YouTube Channel to view detailed videos on both A119S & A119. Support questions are answered the same day.
Browse all BCHobbyist WorkShop videos:


It does not record from time to time.

Sometimes the records do not work.

Seckin, try another memory card.  Do not use SanDisk Ultra cards.  Always format the card inside the camera before using.


Login or Signup to post a comment