Start a new topic

A119s suddenly stopped working

My newly bought A119s dash cam suddenly stopped working. I was using with GPS mount and lexar high endurance sd card. Dash cam suddenly stopped working and now viofo screen alone display when connected to USB power cable and nothing recording. Help me out in solving the problem

Plug directly into the camera and try.
Reinstall the firmware if the above does not work.  Remember to default your settings after reinstalling the firmware.

 

I tried but no luck. When I plug into computer and in car power, VIOFO orange screensaver displaying and POWER on/off alone working. In this case how to reinstall the firmware ? I'm totally lost my hope with this product.

 

Don't use your computer or cars USB ports. They may not have enough power to properly power the camera. Use a USB phone charger to perform the firmware reinstallation. This can work even if the camera won't start properly. I would try it.
Thanks for the reply. What do you mean by USB phone charger? Is it short cable came with the device? Or the long cable that I connect with car power?

 

I could not able to detect the memory card if i plug in a119s device via short cable which came with the device.

 

The charger you use to charge your cell phone. These are usually USB chargers that plug into a wall outlet. Using the long or short cable should work.

I tried connecting with usb charger, firmware is not reinstalling and still orange VIOFO is displaying with rec indicator ON. I could not able to detect memory card if I connect with system. I guess VIOFO itself is not working. Its just 3 week before I bought this product.

mine is doing same thing, after 2 weeks use ~ powers up to start screen and doesn't go any further... tried reset several times, no difference. (and can't reload firmware, as it doesn't fully power up regardless of USB power supplied)

 

The camera doesn't need to fully start to load the firmware. It just needs to get to the point were it senses the memory card and it will load the firmware. Make sure the .bin file (firmware) is on the root directory of the card, not in any folder. Don't use your computer USB port during the update. Use a USB charger (phone charger) in a wall outlet. Default your settings in the menu after updating.

tried same process, still same start screen and doesn't move further.

Is there any fixes for this ? I have the same problem ... 

Camera freezes on start up - can't do anything - tried hard reset, switched cables, switched memory cards etc etc... Nothing works 

Same problem here. Camera just hangs on the "VIOFO" logo. Other forums say viofo is not responding. Let's hope they take care of us

That was fixed in an update awhile back. Update the firmware.
Login or Signup to post a comment