Start a new topic

Corrupted firmware

My Viofo A119 camera got it's firmware corrupted. I solved the problem, but there are some lessons to be learned.


The problem presented itself when I powered the camera and it does not start recording and displays a line of crossed squares on the bottom left side of screen. The buttons do not work, not even power off.


I removed the card and the camera showed the "insert card" message; the buttons work.


I took the camera home and checked the issue online. I found nothing on Viofo forum but Google sent me to Reddit where I found the firmware corruption is a common bug on Viofo cameras.


I checked the card for errors (chkdsk) and there were none. However, and found 3 new files in root (pmp_usb.ini, winamp_metadata.dat and winamp_metadata.idx). I remembered the previous day I had the card inserted into a card reader and I used Winamp for some music. Winamp wrote the 3 files on card and it looks like when I put the card back in camera the things got nasty.


I reinstalled the firmware, and the problem went away.


I don't know if the 3 files caused corruption, but the two events are correlated and worth investigating.


Yeah, the XXXXXX firmware corruption is a known bug.  I don't think I've heard anyone say they found odd files on their card after corruption though.  That's an interesting find.  Will have to ask others when they have this issue whether it occurred after using the card elsewhere (outside the camera).  Would be nice to figure out this issue. 

 

Sadly, I did not save the 3 files, to send them to developers. Also, I do not dare to repeat the incident - I'm afraid I won't be able to recover :)

 

Actually, repeating what you did that you think may have caused the corruption would be very useful. Some users have had this occur a few times and they have always been able to fix it by reloading the firmware.
I repeated the previous steps, but I did not get corruption again.
Looks like it was just a coincidence.

 

Good to know.  Thanks for letting me know.

 

I still keep the Winamp files on card. No corruption since.

 

Login or Signup to post a comment