Start a new topic

A119s suddenly stopped working only by using the usb extension cable provided by viofo

My device is working for a few days and then suddenly stopped. I found out that it was due to the mini usb long cable that came in with the box. Can someone help me to fix this problem. Was this caused by heat inside the car? Or was it power related due to long length of the cable? What cable should i buy? Thanks

Question:  Have you already tried to connect the mini-usb cable directly into the Dashcam (not the GPS mounting bracket?)

 

Yes, with or w/out the gps, it still doesnt work everytime i use the long cable. It works only on the short one. Im really thinking that the long one is defective or maybe it is too long that it cant power up my dash cam. But it seems im the only one experiencing this.
The included long USB cable is not too long and is actually good gauge quality.  You probably have a defective cable.  When you use the short USB cable, are you using the same power supply that you used when using the long USB cable?  If you absolutely sure it's the cable, you should contact your seller for a replacement.

 


1 person likes this
Yes im using the same power/adaptor(the one included in the box) for short cable. The problem is most probably defective cable. Thanks for the replies.. just one question, the long cable worked only for a few days, does heat exposure affect the cable. Is it safe to leave cables inside a car exposed to direct sunlight?
Login or Signup to post a comment